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Customizing an
—xtending
Dreamweaver

One of the best things about Dreamweaver

is that it is both customizable and incredibly |I‘| ThiS Chapter

extensible. What'’s the difference? Customi-

zable means that you can change the key- Customizing Keyboard Shortcuts 2
board shortcuts to suit your style of working, Finding and Installing Extensions 7
and of course you can customize using

Dreamweaver’s Preferences. That’s fine, but

extensibility, the ability to add new features

to the program, is where the real action is.

As you've seen in the rest of our book,
Dreamweaver can do an awful lot. But

just because Dreamweaver is amazingly
capable doesn’t mean that it does absolutely
everything that people want it to do. Adobe
allows software developers to write add-ons,
called extensions, that add new features

to Dreamweaver. These new features can
range from the mundane (adding improved
form handling abilities) to the amazing (creat-
ing full site generators with associated page
templates and navigation bars).

In this bonus chapter, we’ll show you how
to customize Dreamweaver’s keyboard
shortcuts and how to find, acquire, and
install Dreamweaver extensions.
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Customizing
Keyboard Shortcuts

Sometimes the keyboard shortcuts that
come with Dreamweaver aren’t quite what
you want. For example, some shortcut keys
used for editing code with BBEdit (on Mac)
or, for longtime users, the now-defunct
HomeSite (on Windows) aren’t the same as
the shortcuts used for the equivalent com-
mands in Dreamweaver CS5. No problem;
you can change Dreamweaver shortcuts
to match those in your favorite code editor.
In fact, Dreamweaver comes with shortcut
key sets for those two code editors, which
makes it a snap to change shortcut keys
and increase your productivity.

Of course, you can also change any
keyboard shortcut, add shortcuts to menu
items that may not already have them, or
delete shortcut keys you don’t like. You can
also print out a cheat sheet of keyboard
commands to help you learn them.

To change between
shortcut key sets:

1. Choose Edit > Keyboard Shortcuts
(Dreamweaver > Keyboard Shortcuts).

The Keyboard Shortcuts dialog
appears .
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Commands
list

Add shortcut

2.

Rename set

Duplicate set
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Choose the keyboard shortcuts that you
want from the Current set pop-up menu.

Your choices are: Dreamweaver
Standard, which includes the standard
shortcut keys for Creative Suite 5;
Dreamweaver MX 2004, a slightly dif-
ferent set found in a previous version of
Dreamweaver; BBEdit, which modifies
the code editing keyboard shortcuts

to match those used by the popular
Macintosh code editor; and HomeSite,
which modifies the code editing key-
board shortcuts to match the popular
(yet discontinued) Windows code editor.

Click OK.

Dreamweaver changes its keyboard
shortcuts to match the set that you chose.

Export set as HTML

Delete set

Keyboard Shortcuts

Current set: [Dreamweaver Standard

Commands: [Menu commands:

File

Edit

View
Insert
Modify
Format
Commands
Site

Window
4 [ — I

Shortcuts:

Press key:

DI

Delete shortcut

Change

Help

[ ok ][ canel |

-

Q Begin customizing your Dreamweaver experience in the Keyboard
Shortcuts dialog.
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To create a personalized set
of keyboard shortcuts:

1. Choose Edit > Keyboard Shortcuts
(Dreamweaver > Keyboard Shortcuts).

The Keyboard Shortcuts dialog
appears (D).

2. From the Current set pop-up menu,
choose the keyboard shortcuts set that
you want to use as the basis for your
personalized set.

Dreamweaver won'’t let you change
any of the included sets, so you must
duplicate one of them, then modify the
duplicate.

3. Click the Duplicate set button.

The Duplicate Set dialog appears @.
4. Type the name for your duplicate set.
5. Click OK.

Dreamweaver creates the duplicate set
and makes it the active set. You can
then personalize it, as shown next.

To add or change a
keyboard shortcut:

1. In the Keyboard Shortcuts dialog,
choose the kind of command you want
to modify from the Commands pop-up
menu @.

This pop-up menu differs on Windows
and Mac, with more choices (and more
functionality) on Windows. Besides
Menu commands, Code editing, Docu-
ment editing, and Snippets keyboard
shortcuts, Dreamweaver for Windows
also allows you to set keyboard short-
cuts for the Files panel options menu,
the Site panel, and the Site window.

Depending on what you chose, the
Commands list changes.
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Duplicate Set =)

Name of duplicate set: | My keyboard shortcuts|

=2

0 Enter the name of your new keyboard
shortcuts set.

Commands: ‘Mﬂmmnmamis v'
Files panel options menu

Site panel

Code editing
Document editing
Site window
ISnippets

Commands LIRS TR

Code editing

Document editing

Snippets
—

0 You can customize keyboard shortcuts for more
items on Windows (top) than on Mac (bottom).
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Edit i

-+ Zoom In Cirl+=

........ Zoom Out Cirl+
Magnification

........ Fit Selection Ctrl+Alt+0

: ........ Fit All Ctrl+shift+0

........ Fit Width Ctrl+Alt+5hift+0

- Code 52

< I ] 3

0 Click the + buttons to display menu choices in
an indented tree form.

Shorteuts: [+] =)
Press key: Change

G Select the shortcut key that you want to change.
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. In the Commands list, navigate to the

command that you want to change. Click
the + icon next to the name of the menu
to expand the choices for that menu.

The menu choices are shown with any
existing shortcut keys @.

. Click on the command that you want

to change.

The shortcuts assigned to the command
appear in the Shortcuts text box @.

. To add a shortcut, click the Add short-

cut button (marked with a plus sign).

A new blank line appears in the Short-
cuts text box.

or

To change an existing shortcut, select it
in the Shortcuts text box.

. Click in the Press key text box.

. Press the key combination you want to

use for the shortcut key.

If the key combination is already in use,
Dreamweaver lets you know with a
message at the bottom of the Keyboard
Shortcuts dialog.

Click Change.

The new shortcut appears in the Short-
cuts text box.

. Click OK to save your changes and

dismiss the Keyboard Shortcuts dialog.
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To export a keyboard

command cheat sheet:

1. Choose Edit > Keyboard Shortcuts
(Dreamweaver > Keyboard Shortcuts).
The Keyboard Shortcuts dialog
appears 0.

2. Click the Export set as HTML button.
The Save as HTML file dialog appears.

3. In the Save as text box, give the
exported file a name, then navigate to
where you want to save the HTML file.

4. Click Save.

Dreamweaver saves the list of key-
board commands to your hard disk as
an HTML file. You can then open it in
Dreamweaver or any Web browser @.

Note the bug in Dreamweaver shown in
figure (. The heading in the exported HTML
page says “Dreamweaver CS3” rather than
referring to CS5. Oops.
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o You can print your keyboard command cheat
sheet from a Web browser.

6 Customizing and Extending Dreamweaver



http://www.dreamweaverbook.com

"Dreamweaver CS5: Visual QuickStart Guide" Bonus Material
Excerpt Copyright © 2010 Tom Negrino and Dori Smith

http://www.dreamweaverbook.com

Finding and Installing
Extensions

You add extensions to Dreamweaver using
Adobe Extension Manager, a program

that was installed when you installed
Dreamweaver on your system. After you
install an extension, it appears as part of
Dreamweaver. Where it appears within the
program depends on what kind of exten-
sion it is. For example, if you have installed
an extension that allows you to easily add
Google search boxes or maps, that exten-
sion would appear in the Insert menu. An
extension that provides new ways to add
pop-up menus may appear in the Com-
mands menu. And extensions that add
new scripting behaviors will appear in the
Behaviors panel. Because Dreamweaver is
almost infinitely extensible, the extensions
you add can appear almost anywhere
within the program.

You can find extensions in a variety of
ways. Some extensions are free for down-
loading and others are paid products.
Many extension developers have Web
sites where they host (and sometimes
sell) their extensions. A Google search for
“Dreamweaver extensions” will result in a
large number of useful results.

But the most common way to find Dream-
weaver extensions (and also extensions for
other Adobe products, such as Photoshop,
Fireworks, Flash, etc.) is to use the Adobe
Exchange site, at www.adobe.com/exchange/.
The Dreamweaver Exchange portion of the
site has lists and short descriptions of more
than fifteen hundred extensions.
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In Dreamweaver, it’s easy to go to the
Dreamweaver Exchange site. Just choose
Help > Dreamweaver Exchange, and your
default Web browser opens to the site ).
From the Exchange site, or from an exten-
sion developer’s site, download the exten-
sion file to your hard disk. Then you’re
ready to use Adobe Extension Manager to
install the extension.

{@ Adobe - Dreamweaver Exchange - Mozilla Firefox [ESEEN =
Eile Edit View History Bookmarks Tools Help

o+ C Ay (I hetpy/wwwadobe.com/cfusion/exchange/index.cim?s=5& o= descitexca 3&event=producttom 17 = | [#- Gaogle £l R

ﬂ Search l

[ 147 Adobe - Dreamweaver Exchange | = |

Youraccount | B= | Contact | United States (Change)

Solutions Products Support Communities Company Downloads Store

Dreamweaver Exchange

Most Recent Most Popular Highest Rated

Search D

License type | All : Filter
110011594 [<][v]
Search

Validator for Dreamweaver CS5 Download | . cad search
Reinstalls the Validator feature for Dreamweaver CSA. -
Win | Mac
451KD  DREAMWEAVER EXCHANGE HOME
By Donald Booth 15-Jun-10 20 downloads
S A A AL A

BROWSE BY CATEGORY

All

Accessibilty
HTML5 Pack for Dreamweaver CS3 and CS4 | Download | e

Code hinting for HTMLS and CSS3. Win | Mac | Browsers

By Donald Booth 15-Jun-10 67 downloads 3288KB  Commerce

+ Content
C3S Layouts
DHTML/Layers
Google Maps Get the Widget Browser Extension Development
The Google Maps Widget lets you add Google Maps to your own web pages. Firewiorks
Flash Media
Framework: Google Ay 2
< I, ] v
Done #*®

o The Dreamweaver Exchange site lists more than a thousand extensions.

8 Customizing and Extending Dreamweaver


http://www.dreamweaverbook.com

"Dreamweaver CS5: Visual QuickStart Guide" Bonus Material
Excerpt Copyright © 2010 Tom Negrino and Dori Smith http://www.dreamweaverbook.com

To install an extension:

1. Ifit’s running, quit Dreamweaver by
choosing File > Quit (Dreamweaver >
Quit).

2. Launch Adobe Extension Manager by
double-clicking its icon.

On Windows, launch the program from
the Start menu. On Mac, you'll find it
in /Applications/Adobe Extension
Manager CS5/.

The Adobe Extension Manager window
appears ©.

continues on next page

Go to Adobe Exchange
Remove selected
Installed extensions list Install extension extension

(Qg ADOBE" EXTENSION MANAGER CS5 '& Install

File Help
PRODUCTS Enabled Extension Versior Author
¥ Fireworks css5 | .*. Dreamweaver HTMLS Pack  1.0.0 Adobe Systems, Inc. Remove
Dreamweaver CS5
s Photoshop CS5
InDesign CS5
Bridge CS5

Contribute €55
Description Advanced

This extension provides initial support for HTMLS and CSS3 in Dreamweaver CS5. While
HTMLS and CSS3 will not be finalized for some time, the extension provides support for a
set of currently implemented features.

This extension enhances Dreamweaver CS5 in the following ways:
*Updates code hinting for the HTMLS Tag Library with new tags, attributes, and
properties.
*Updates code hinting for new attributes and values in existing HTML tags.
*Multiscreen Preview allows for viewing multiple screen/device sizes at once, with
media guery support.
*Updates WebKit to support <video> and <audio> in Live View, along with some CSS3
properties. (Requires QuickTime installation.)
*Adds HTMLS starter layouts to the New Document dialog box.
*QOffers better rendering for new tags in Design View.
*Adds code hinting for the following CSS3 specifications:
2D/3D Transformations
Animations
Background and Border
Basic User Interface

Products list Extension description

0 Use the Adobe Extension Manager program to install or remove extensions.
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3. From the Products column on the left
side of the window, choose Dream-
weaver CS5.

Any extensions you have installed
for Dreamweaver CS5 appear in the
Installed extensions list.

4. Click the Install button.

The Select Extension to Install dialog
appears @.

5. Navigate to and select the extension
file you wish to install.

6. Click Open (Select).
A license dialog appears.
7. Click Accept.

The Extension Manager installs the
extension and reports success with an
alert dialog.

8. Click OK to dismiss the alert dialog.

The new extension appears in the
Installed extensions list.

9. Choose File > Exit (Extension Manager >
Quit Extension Manager).

10. Launch Dreamweaver to use the new
extension @.

If you have more than one version of
Dreamweaver installed (perhaps you didn’t
want to remove an older copy immediately
when you upgraded to Dreamweaver CS5),
you can have different sets of extensions
installed for each version.

Because each extension works differ-
ently, you need to refer to the instructions
that came with the extension to discover
how to access the extension from within
Dreamweaver.
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@ Find and select the extension file that you want
to install.

Step 1 of 3:Search options

This wizard will add a search field to your web page, enabling visitors to search your
website or the entire web. This is a free service from Google. View Terms of Service.

Search Type

WebSearch
WehSearch with SiteSearch

Domain: Www.yourdomain.com

Enable SafeSearch to exclude adult-themed content from results

o ®o

Preview

Google Search

O wWww e www.yourdomain.com

Googler

b—-—im_‘;-ﬂi-;-]

0 Extensions can provide a complete user
interface, as in this example, Tools for Google,
which helps you easily create a Google search
box, map, or other Google services on your site.

WEBASSIST®
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